how to program Olimex PIC32-Pinguino-OTG board

Asked by ntronics at 09:15 on 13 Sep 2017.

Hi Matt, the UECIDE says "No target found" when I attempt to program Olimex PIC32-Pinguino-OTG board. It is identified by UECIDE not as COM port but as PIC32 Pinguino OTG (Olimex bootloader). What am I doing wrong?

Sign up or log in for live updates and to post messages.

I should have RTFM. It needs a different bootloader to work with UECIDE

Posted 13 Sep 2017, 09:37, 0 votes
ntronics
Rating: 0

I thought I had a special board set up for the olimex version - maybe not for that board though...

It takes quite a bit to get it working with the native bootloader - a whole new linker script, etc.

Posted 13 Sep 2017, 09:40, 0 votes
matt
Rating: 3

Matt, I have a different problem with this board after flashing Olimex_PIC32_Pinguino.hex bootloader from chipKIT32 github repository. Program flashed onto olimex board is getting lost on reset/power cycle. This happens on three different boards, two of which are brand new. This makes me wonder if I flashed the correct bootloader version? I could not find pinguino bootloader file with OTG suffix.

When olimex-pinguino32-otg board was installed using plugin manager, "PIC32 Pinguino OTG (Olimex bootloader)" option was added into the Hardware menu. This is not what I expect to see there because it is not an olimex bootloader version. Can this be relevant to reset issue?

Posted 13 Sep 2017, 12:04, 0 votes
ntronics
Rating: 0

The Olimex Bootloader programmer should work with the stock Olimex bootloader, not the chipKIT one. For the chipKIT (if it is the right version) bootloader you can just ignore that programmer and use the normal pic32prog one.

Posted 13 Sep 2017, 12:21, 0 votes
matt
Rating: 3

I flashed the original bootloader but unable to test it because UECIDE is stuck at splash screen with Editor... message shown in the red status progress bar. Tried rebooting pc but it did not help. Is there any way to reset UEIDE without re-installation?

Posted 13 Sep 2017, 13:41, 0 votes
ntronics
Rating: 0

It sounds like a plugin has gone bad. Remind me what OS you are on?

Posted 13 Sep 2017, 13:52, 0 votes
matt
Rating: 3

Windows 10 x64

Posted 13 Sep 2017, 13:52, 0 votes
ntronics
Rating: 0

Ok, there's two things you can do:

  1. Remove your preferences.txt
  2. Remove your entire UECIDE data folder

C:\Users\<username>\AppData\Local\uecide is where things are located. Find preferences.txt in there and delete it - that will reset your preferences to default. If that fails then you can delete the whole lot, though it'll then mean reinstalling all the packages.

If you leave behind apt\cache (I think it's called) then you shouldn't need to download the files again, only install them.

Posted 13 Sep 2017, 13:54, 0 votes
matt
Rating: 3

Thank you Matt. UECIDE is working again after deleting preferences.txt.

But can't program the board with the original olimex-pinguino bootloader. "No target found" error message is shown. Everything is setup as shown in the attached pictures.

Posted 13 Sep 2017, 14:16, 0 votes
ntronics
Rating: 0

Problem solved. I found another bootloader for this board. It is compatible with UECIDE olimex-pinguino32 board package and uses ordinary COM port to flash programs.

There may be a problem with how UECIDE manages olimex packages. If both olimex-pinguino32 and olimex-pinguino32-obl are installed then only one board is shown in Hardware->Boards menu. It looks like olimex-pinguino32-obl overwites or corrupts olimex-pinguino32

Posted 13 Sep 2017, 15:27, 0 votes
ntronics
Rating: 0

Oops. I'll have to check that out...

Posted 13 Sep 2017, 15:32, 0 votes
matt
Rating: 3

Matt, this board has two UART ports. Serial1/UART2 is working fine, while Serial object sends data to USB port instead. How can I change it to use use UART1 pins instead?

I noticed that if Fubarino SD board is selected then Enable/Disable USB serial menu options are available in UECIDE, but they are missing if PIC32 Pinguino board is selected. Is this relevant to UART1 problem?

Posted 19 Sep 2017, 12:20, 0 votes
ntronics
Rating: 0

In chipKIT the serial ports, without USB, are numbered:

  • Serial
  • Serial1
  • Serial2
  • ... etc ...

With USB they change to become:

  • Serial (USB)
  • Serial0
  • Serial1
  • Serial2
  • ... etc ...

So Serial0 is the object you are looking for.

Posted 19 Sep 2017, 12:40, 0 votes
matt
Rating: 3

Thank you Matt. Serial0 works fine now, zero index is the only one I haven't tried

Posted 19 Sep 2017, 13:01, 0 votes
ntronics
Rating: 0

I'm not sure whose idea it was to change the numbering like that when you have USB. Personally I'd have kept them the same and named the USB serial port something else, like USBSerial.

Posted 19 Sep 2017, 13:02, 0 votes
matt
Rating: 3

Yes it's a bit confusing to say the least

Posted 19 Sep 2017, 13:06, 0 votes
ntronics
Rating: 0

This site uses cookies to maintain your current login session and improve your browsing experience. By continuing to use this site you agree to the placing of these cookies on your computer or device.

About cookies | Close this popup