auto format not working

Auto format does not work.

Unable to start process Cannot run program "/tmp/astyle" (in directory "/tmp/build-0e0c52ce-af8a-46ca-baa6-1eb10bca3d2f"): error=2, No such file or directory

Any suggestion?

Comments

Sounds like you are using an

Sounds like you are using an old version. Astyle has been broken out into a javascript plugin / tool. Install it from the plugin manager.

The /tmp/astyle is a binary

The /tmp/astyle is a binary that would get extracted from the old .jar plugin. Now we don't have .jar plugins those were moved into the core jar file instead - however it became impossible to then extract it using the existing code, so I made it into a combination of a tool and a javascript plugin.

You need to have both Plugins -> Programming -> Artistic Style Formatter and Tools -> Programming -> Artistic Style Executable. The latter didn't seem to be in the repository for some reason, but I've added it now. Installing the first one should automatically install the second one - and it'll give you a Tools menu entry of "Auto format with Artistic Style" and a button on your editor tab toolbar.

I completely removed UECIDE.

I completely removed UECIDE. Did a new install. Removed the artistic style formatter. Selected it again. Nothing was of much help. Same message pops up.

The tools menu entry was already available. Nothing new there. In the editor tab of the main screen is nothing new. In the editor tab of preferences there is "toolbar". It contains "Hide the secondary editor toolbar". Selection does not seem to have any effect.

I did a complete reinstall

I did a complete reinstall from Ubuntu and the whole lot.

By the way, after a few times starting UECIDE in ubuntu, the UECIDE opening screen appears, but gets stuck.

Uecide is not loading. Only "Opening editor ..." and that is all.

Because of that I did another complete reinstall, with the same result.

??????

I still don't know what

I still don't know what version you're running.

Doing a reinstall of UECIDE has no effect. Instead you would want to "clean" your installation. Delete the directory ~/.uecide to remove all installed packages and settings. Then it becomes a freshly installed system.

I did a clean install of

I did a clean install of UBUNTU and ALL software, including UECIDE. That means I was using the latest version of UECIDE.

This version gets stuck during start-up

Oh right, I misunderstood.

Oh right, I misunderstood.

To find out why it's getting stuck, run:

uecide --exceptions

from a terminal. Look for any exceptions it gives you on the terminal.

Warning: substituting default

Warning: substituting default font for missing font Monotype

several lines

Warning: Nashorn engine is planned to be removed from a future JDK release

4 lines

Than Uecide starts.

After closing terminal and starting UECIDE in a normal way, it gets stuck again

So you're using 0.10.6 at the

So you're using 0.10.6 at the moment? Try running the latest beta version - 0.11.0 Beta 3.


Actually, I'm just uploading my latest development version now as 0.11.0 Beta 4. Try that.

And how did you install

And how did you install UECIDE? The tgz file, the deb file, or did you use the repository and apt-get?

Tools > Plug-in manager >

Tools > Plug-in manager > Tools > Programming > Artistic Style Executable

results in two lines with "Auto format with Artistic Style" in pull-down menu "Tools"

No other result is to be noticed.

Formatting still does not work.

Yes, you are on an old

Yes, you are on an old version with the broken one built in. One should work, and one should be broken. You should also get two icons in your editor toolbar - one would work, and one not. Ignore the one that doesn't work - it's gone from newer versions of the IDE.

I tested both.

I tested both. Both are NOT working. The error messages are:

Unable to start process Cannot run program "/tmp/astyle" (in directory "/tmp/build-96ade461-3292-4d07-99b3-75b3c1a05398"): error=2, No such file or directory

Unable to start process Cannot run program "/home/ellard/.uecide/tools/astyle/bin/linux_amd64/astyle" (in directory "/tmp/build-96ade461-3292-4d07-99b3-75b3c1a05398"): error=2, No such file or directory

Can you make sure the program

Can you make sure the program /home/ellard/.uecide/tools/astyle/bin/linux_amd64/astyle actually exists? This may be a packaging error, or it could be a library problem in your OS (you get the same error if it's a 32-bit binary and you don't have 32-bit support installed).

ellard@workhorse:~$ cd /home

ellard@workhorse:~$ cd /home/ellard/.uecide/tools/astyle/bin/linux_amd64/

ellard@workhorse:~/.uecide/tools/astyle/bin/linux_amd64$ ls

astyle

ellard@workhorse:~/.uecide/tools/astyle/bin/linux_amd64$

Yes, I guess it's a 32-bit

Yes, I guess it's a 32-bit binary. Install the package "libc6-i386" in Ubuntu. You need it for running any 32-bit applications - and that includes some compilers. It's kind of an essential package that you should always install immediately you have installed Ubuntu.

At the moment ubuntu sucks.

At the moment ubuntu sucks.

It complains about system problems. I have them reported.

Uecide does not load at the moment. Startup window halts.

I guess a new fresh install is required again.

You don't seem to be having

You don't seem to be having much luck with Ubuntu, do you? Maybe you should give Mint a go instead. Same base as Ubuntu, but packaged by different people and with a different look to it.

I have upgraded astyle to 64-bit for the amd64 architecture, so it should work now if you update it.

I re-installed ubuntu with

I re-installed ubuntu with libc6-i386. I installed uecide fresh again. Formatting is working now.

When I get problems again I will follow your suggestion and install Mint.

Thanks.

Pages