Compilation problem

At first I would like to mention the main problem I experienced:

Software which compiled nicely with version 10.6 does not compile anymore albeit that error reporting is VERY extensive.

Comments

Aside from a conflict with an

Aside from a conflict with an ESP32 library I had installed (AsyncTCP vs ESPAsyncTCP, which happens to contain AsyncTCP.h...) I just compiled that fine. Mind you, I have recently done a huge amount of work on both the ESP8266 and ESP32 cores to rebuild them from the ground up, and that may well have an effect. Both cores (and their associated boards which have also been rebuilt) are in the testing repository at the moment. Feel free to try them out.

I just tried to compile again

I just tried to compile again to be sure that I am not doing something wrong. On my machine with Linux Mint the compilation stops with error messages.

Hi Matt

Hi Matt

I just compiled the simple "Blink" program.

It does NOT compile. Error messages in file.

I hope you can do something, because I can not proceed at all. Where can I download the testing repository?

Attachments: 

Those errors look like a

Those errors look like a corrupt cache. Have you tried doing a clean compile? (shift-click the compile button).

To get the testing repository just install the testing repository package in the package manager and hit the refresh button. Be warned though it may need some massaging to get the newer packages set up and working (there may be some extra packages that need manually installing).

Ok, you're lacking the ${tool

Ok, you're lacking the ${tool:...} variable command script. That should be in the core-varcmd package. Make sure that's on version 1.1.2. I think you'll need the testing repo for that. This is one of the aspects that I have overhauled in that version.

Oh, and I just used your

Oh, and I just used your sketch as a test for my development branch of UECIDE, on which I have been re-writing the entirety of the Library handling system today. On the release version it takes about 43.276 seconds to do a full compile on my system. However the development branch has that same clean build down to just 15.813 seconds :)

It did help me find some corner cases with my new library system, so that's been a big help.

That sounds good to me.

That sounds good to me.

But I am sorry to say that my knowledge and ability are falling short to help me any further.

Would it be possible for you to recompile the latest release with the missing software module incorporated. That would allow me to proceed with developing my software.

Thanks

Since the existing esp8266

Since the existing esp8266 core is broken I shall release the new version to the live repository. That should hopefully fix things.

Ok. If you go into the plugin

Ok. If you go into the plugin manager, do a "Refresh" and "Upgrade All" that should get you the working version. You may also have to manually install the "Python" package in there as well. It's marked as a dependency of esptool but it doesn't install it automatically with an upgrade, only a fresh installation.

I get:

I get: Error: Resource not found: /org/uecide/dist/pool/main/c/core-varcmd/core-varcmd_1.1.2_all.deb

Almost there.

It shouldn't be even looking

It shouldn't be even looking there for it. I think you may have made a mess of your installation. I'd recommend maybe wiping your .uecide folder and starting from scratch.

I do not like to admit it but

I do not like to admit it but you were right.

I now can go on with developing my software.

I would like to compliment you with the way you support your users.

Thanks

Hi Matt.

Hi Matt.

An issue still exists.

The error reporting has a hickup. At first I thought nothing serious about it but it prevents normal working while no reports about upload results also.

I tried to "upgrade" but no positive result (nothing to upgrade)

Attachments: 

Ok, there was a package I'd

Ok, there was a package I'd missed off uploading. Back to the plugin manager, refresh it, and look for the "esp-elf2bin" package. And of course make sure all packages are upgraded fully.

Hum. That's all correct. So

Hum. That's all correct. So why isn't it finding it?

The configuration line in question is

compile.autogen.bin=${tool:esp-elf2bin,run}::--eboot::${core.root}/bootloaders/eboot/eboot.elf::--app::${build.path}/${filename}.elf::--flash_mode::${build.flash_mode}::--flash_freq::${build.flash_freq}::--flash_size::${build.flash_size}::--path::${compiler:root}/bin::--out::${build.path}/${filename}.bin

That calls run in the esp-elf2bin tool, which looks like:

run=${tool:python,run}::${tool:esp-elf2bin,root}/elf2bin.py

Which in turn calls run in the python tool, which looks like:

run=/usr/bin/python

So the result after replacement should look like:

/usr/bin/python::${tool:esp-elf2bin,root}/elf2bin.py::--eboot::${core.root}/bootloaders/eboot/eboot.elf::--app::${build.path}/${filename}.elf::--flash_mode::${build.flash_mode}::--flash_freq::${build.flash_freq}::--flash_size::${build.flash_size}::--path::${compiler:root}/bin::--out::${build.path}/${filename}.bin

That you're just getting the command starting with --eboot (you can turn on verbose command execution in preferences and switch to the "Output" tab to see the actual commands being executed) tells me that the replacement of ${tool:esp-elf2bin,run} isn't happening.

I think I'm going to have to replicate your system in a VM as close as I can and do a test installation of UECIDE in there. You're on Mint, yes? What version? What architecture?

I have to say I really don't

I have to say I really don't know. There is something about your system that hates UECIDE, and I'd love to know what it is.

You do just have a basic Mint installation? Nothing "strange" like your home directory is shared with Windows, or mounted from a network share or anything like that?

I can't see Ubuntu making a

I can't see Ubuntu making a difference, since they're both the same under the hood anyway (Mint is Ubuntu with a better interface by default).

Instead of reinstalling Mint you could try setting up a fresh Mint VM to try it in. libvirt, virt-manager, kvm etc are your friends here.

I did a fresh install.

I did a fresh install.

Unless I download the tar.gz version I end up with the 0.11.4 version instead with the 0.11.5 version.

Compilation is OK.

But something else is now causing problems

Attachments: 

Also I'm just releasing 0.11

Also I'm just releasing 0.11.7 which has the newest versions of things like core-varcmd, ctags, etc bundled into it. I'll be fixing the .deb at the same time.

Pages