Localization of a lib isn't quite that easy

I suspect it may have to do with capitalization? This is my problem:

I downloaded a lib as a zip file and installed via uecide. This lib: https://github.com/maarten-pennings/CCS811.

Ran the provided examples, and all worked fine. Then tried to integrate into my sketch. This lib also had some hardcodings which I need changed, so I localized it. Easy, the lib shows up under my sketch folder.

I include with #include "ccs811.h".

But neither restarting uecide or clean-compiling or both would make uecide take the localized lib. It insists on the first installed one, even if I rename the lib folder to 'xxx'?

The one thing I noticed is that the lib folder is CCS811, while the source files are ccs811.h and *cpp. So I renamed folder and files to either all big cap or all small cap. No success.

Are the libs additionally registered somewhere else in uecide ?


Capitalisation is important

Capitalisation is important in UECIDE. It's a hangover from the old MPIDE days. The folder for the library must be named the same, including capitalisation, as the main header file. That's how it works out what a library is.