no programmer on ESP8266

Salut, I try to program an esp8266 module. I selected "Generic ESP8266 Module" and all compiles well but there is no programmer I can select although the esptoool got tagged and installed while installing the esp core. The module I am using is a esp-01 on a programming breakout that gets me the serial port and the GP02 to groun for programming When I select an ESP32, the programmer is "esptool for esp32"

What am I overlooking? Ciao, Mathias

Comments

Btw: I checked in the Plugin

Btw: I checked in the Plugin Manager, that the esptool is instaled as programmer but when I go into Preferences, I do not see esptool as programmer - perhaps that helps (I can talk to the esp8266, so no hardware issue) Ciao, Mathias

UECIDE is calling esptool but

UECIDE is calling esptool but leaves out the baud rate:

[2019-02-15 19:31:10.569] Context.java 1063 (runSystemCommand): Execute: c:\UECIDE\programmers\esptool/tools/windows/esptool -cd ck -cb -cp COM33 -ca 0x00000 -cc esp8266 -cf C:\Users\A681818\AppData\Local\Temp\build-9c5c405f-523e-4979-a6f2-12758c804e58/mqtt_esp8266.bin 

calling it manually with -cb 115200 (and -vv for verbose) works. Baud rate is set in the options:

#pragma option CpuFrequency = 80
#pragma option CrystalFreq = 40
#pragma option Debug = Disabled
#pragma option DebugLevel = None____
#pragma option FlashErase = none
#pragma option FlashFreq = 40
#pragma option FlashMode = qio
#pragma option FlashSize = 512K0
#pragma option LwIPVariant = v2mss536
#pragma option ResetMethod = ck
#pragma option UploadSpeed = 115200
#pragma option led = 2
#pragma option warnings = on

Ciao, Mathias

I can tell you're not using

I can tell you're not using Linux. The option was there on the Linux variant of the command...

works now with the latest

works now with the latest update! I know that you touch windows only with water pump pliers (German joke). That´s why I am extending your test bench to this weird OS. But I am stuck for business reasons with Windows so I make the best out of it. Ciao, Mathias