UECIDE 0.10.0 RC2 Windows issues

Saut Matt,

I odwnloaded the RC2 version for Windows (zip,lite) and when I start it and launch the Plugin Manager, the Refresh button gets me this error below: Update: res://org/uecide/dist/dists/uecide/boards/binary-windows-amd64/Packages.gz ... done
Update: res://org/uecide/dist/dists/uecide/main/binary-windows-amd64/Packages.gz ... done
Update: res://org/uecide/dist/dists/uecide/compilers/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/uecide/dists/uecide/main/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/nightly/dists/uecide/themes/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/nightly/dists/uecide/cores/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/nightly/dists/uecide/plugins/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/nightly/dists/uecide/extra/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/nightly/dists/uecide/repos/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/nightly/dists/uecide/libraries/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/nightly/dists/uecide/boards/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/nightly/dists/uecide/main/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/nightly/dists/uecide/compilers/binary-windows-amd64/Packages.gz ... done
Update: http://repo.uecide.org/nightly/dists/uecide/tools/binary-windows-amd64/Packages.gz ... java.io.FileNotFoundException: http://repo.uecide.org/nightly/dists/uecide/tools/binary-windows-amd64/Packages.gz
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection$10.run(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection$10.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at sun.net.www.protocol.http.HttpURLConnection.getChainedException(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at org.uecide.Source.getCompressedFileHTTP(Source.java:65)
at org.uecide.Source.getPackages(Source.java:120)
at org.uecide.APT.update(APT.java:284)
at org.uecide.APT.update(APT.java:271)
at org.uecide.PluginManager$16.doInBackground(PluginManager.java:813)
at org.uecide.PluginManager$16.doInBackground(PluginManager.java:801)
at javax.swing.SwingWorker$1.call(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at javax.swing.SwingWorker.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.io.FileNotFoundException: http://repo.uecide.org/nightly/dists/uecide/tools/binary-windows-amd64/Packages.gz
at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getHeaderField(Unknown Source)
at java.net.URLConnection.getHeaderFieldLong(Unknown Source)
at java.net.URLConnection.getContentLengthLong(Unknown Source)
at java.net.URLConnection.getContentLength(Unknown Source)
at org.uecide.Source.getCompressedFileHTTP(Source.java:64)
... 11 more

Error downloading http://repo.uecide.org/nightly/dists/uecide/tools/binary-windows-amd64/Packages.gz: http://repo.uecide.org/nightly/dists/uecide/tools/binary-windows-amd64/Packages.gz
done
0 packages can be upgraded.

Tags: 

Comments

Those are generally non-fatal

Those are generally non-fatal errors. It just can't find anything matching those categories on the nightly build server. I need to purge and re-build that server sometime since it's out of date anyway. For now just remove the nightly repository package.

I have added the missing

I have added the missing "tools" section to the nightly server, and purged all the old packages from it so there's nothing there anyway now. I've also hidden and ignored the "file not found" exception in the plugin manager, so should never show again.

ok- error is gone and I was

ok- error is gone and I was able to compile a demo sketch (LCD autoscroll)

By the way: I am currently in a hospital after a hip surgery and the network is slow, really slow. When I start UECIDE there seems to be a network based startup step as it has a long moment of no activity which I do not recognize at home with high speed DSL. If there is such a network check, it may be nice to have a selection to flag "slow network". Ciao, Mathias

That may be it checking the

That may be it checking the current version. You can try setting "Work in offline mode" in Preferences under Network - or add the --offline command-line flag. I can't remember off hand all the things it does at startup, but version checking is one. It also checks certain packages are up to date with its internal copies - though that should only be looking at the internal repository, not internet-based ones.

missing plugins:

missing plugins: I cannot spot the following plugins: re-load last HEX file, Grapher, program bootloader (via the Tools menu), ArduBlocks, Copy for Forum (via Edit menue). The jpl file for refreshing all internal structures, you gave me some time ago, is not recognized as well.

Ciao, Mathias

There are no plugins any

There are no plugins any longer. All things are integrated directly - you can turn them on and off in preferences. I had to do this because Java 10 broke plugins in a horrible horrible way.

Ardublocks is just an editor now - you can right click on your sketch files folder in the tree and create an ardublocks file.

The grapher is trash. It needs rewriting from scratch. It was never any good.

The JPL file should work - I haven't (as far as I know) touched that side of things. However, I'll take a look at it tomorrow and see if I can make one run.

Ok, so I had a quick look at

Ok, so I had a quick look at the javascript plugins problem before going to bed. I had nerfed it when I changed how I do toolbar buttons. It was all working perfectly fine - I just wasn't actually adding the icon to the toolbar. Oops?

Salut, plugin works now after

Salut, plugin works now after I enabled them in the preferences. I got confused as the plugins are still selectable in the plugin manager, but with the recent changes, slecting the plugins in the plugin manager has no effect. I suggets to drop them as items in the plugin manager and prehaps rename the "plugin manager" to "Features Manager" or "Options Manager"

My delay at startup is linked to the preference to check for a new editor at startup Ciao, Mathias

Yes, the "plugins" need to

Yes, the "plugins" need to still be in the "plugin manager" (there's two meanings for "plugin" here...) for older versions of the IDE. I could get it to filter out the Plugins and Themes branches of the tree though I guess in the IDE itself, although I do have plans for Plugins in the Plugin Manager in the future.

I use the term "plugin" for both "IDE extending plugins" (deceased) and "Boards, compilers, programmers, tools, JPL plugins (eventually)" etc. I don't really want to call it "Boards Manager" like the Arduino IDE because it's far more than just boards. Not sure about Features or Options either.