Uecide loading problem

Hi Matt

Uecide hangs again during start-up on Linux Mint. As you asked me the previous time I now do have the error message from the terminal window:

ellard@funbox:~/Software/uecide-0.11.5$ ./uecide
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.uecide.Base (file:/home/ellard/Software/uecide-0.11.5/uecide.jar) to field java.lang.ClassLoader.scl
WARNING: Please consider reporting this to the maintainers of org.uecide.Base
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
0 packages can be upgraded.
Warning: Nashorn engine is planned to be removed from a future JDK release
Warning: missing font Monaco
Warning: substituting default font for missing font Monaco
Warning: substituting default font for missing font Monaco
Warning: substituting default font for missing font Monaco
Warning: substituting default font for missing font Monaco
Warning: substituting default font for missing font Monaco
Warning: substituting default font for missing font Monaco
Warning: Nashorn engine is planned to be removed from a future JDK release
Warning: substituting default font for missing font Monaco
Warning: substituting default font for missing font Monaco
Warning: substituting default font for missing font Monaco
Warning: substituting default font for missing font Monaco

I hope this will help you solving the issue.

Comments

Close. But I have changed the

Close. But I have changed the error reporting slightly (made it better).

You now need to run UECIDE with --exceptions to get the needed error messages. You can also add --log=uecide.txt to put it all in a file that you can attach here.

Ok. At a guess I would say

Ok. At a guess I would say that you have "open last sketch" turned on in preferences and the "last sketch" is corrupt in some way.

Find your preferences.txt file (in ~/Library/uecide maybe?) and look for the line editor.save.loadlast=true and change it from true to false. That should enable it to load.

I have seen (and cured) a similar problem where I loaded a file . (when in the folder of a sketch) and it broke giving the same error. It's something I have cured in the development branch, but that branch isn't usable yet.

I tried to find a file

I tried to find a file "preferences.txt". Two popped up but not from UECIDE.

The situation is as follows:

I removed UECIDE 10.6 with the software manager. I downloaded 11.05 as tar. Installed it. When I Run UECIDE via the terminal I get the error messages.

P.S. the .deb version can not be downloaded (404)

Alternatively you can try:

Alternatively you can try:

ellard@funbox:~/Software/uecide-0.11.5$ ./uecide --set=editor.save.loadlast=false

That should have the same effect.

Pages