USB serial port issue

Primarily I am working on a MacBook Air. When I disconnect a module from the USB cable and hook up another module, the USB port is in use again as soon as I plug the cable into the port of the second module.
Recently I started using a windows box to evaluate the interaction between two modules.
When I change modules on the windows machine, the USB port stays occupied in UECIDE. (Exception type - Port already open). To solve this issue I have to close UECIDE and start UECIDE again.
Would you have a look into this issue?

Comments

I just tried it again to be

I just tried it again to be sure. When I have a working serial monitor on my Mac I just pull the plug from the module. I put the plug in another module and that one starts booting, without any problem.
When I pull the plug out of a module which is connected to a winbox, the port stays "open". I have to close UECIDE to be able to use the serial port again.

Yes, this is a known problem

Yes, this is a known problem in Windows. There is no way that I have found yet that lets me know whether the port is still there or not. Windows is rancid in that respect. On OS X and Linux I just check for the presence of the /dev node, but that's not possible on Windows. Not even \\.\COM3 can be tested for presence.

Pages